`
king_tt
  • 浏览: 2108797 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
社区版块
存档分类
最新评论

UVa 10340 - All in All

 
阅读更多

链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1281


原题:

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two stringssandt, you have to decide whethersis a subsequence oft, i.e. if you can remove characters fromtsuch that the concatenation of the remaining characters iss.

Input Specification

The input contains several testcases. Each is specified by two stringss, tof alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, ifsis a subsequence oft.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No


分析与总结:
简单题,直接判断一个字符串是否是另一个字符串的子串。

代码:
/*
 *  UVa: 10340 - All in All
 *  Time: 0.008s
 *  Author: D_Double
 */
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str1[1000000], str2[1000000];

bool judge(){
    int pos=0, i;
    for(i=0; i<strlen(str1); ++i){
        bool flag=false;
        while(pos < strlen(str2)){
            if(str2[pos]==str1[i])
                break;
            ++pos;
        }
        if(pos==strlen(str2)) return false;
        ++pos;
    }
    if(i==strlen(str1)) return true;
    return false;
}

int main(){
    while(scanf("%s %s",str1,str2)!=EOF){
        if(judge()) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

—— 生命的意义,在于赋予它意义。

原创http://blog.csdn.net/shuangde800By D_Double (转载请标明)



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics